help with aeon labs multi -sensor

Developer
Dec 3, 2012 at 5:50 AM

I have downloaded the latest code, and tried running the example console app 

which does correctly discover my aeon labs multi - sensor, .  

When I press the wake up key on the sensor,  a wake up event is correctly scene 

by my controller.  

however,  no motion is being detected.  

The spec for the sensor says that I must associate a device with the sensor in order for it to send the motion event.  

I am brand new to zwave and am having some difficulty understanding how to associate my controller ( aeon labs usb sticK),  to the sensor,  or vice versa.  

I basically just want the controller to get the event and let  my software will handle what to do from there .

Has anyone been able to configure one of these sensors to work?,  any and all help appreciated as I am a bit lost ...

thanks ,

Nick P.

Coordinator
Dec 3, 2012 at 6:57 AM

Hi Nick

I have not had that specific sensor working, but something similar. The association classes are currently not implemented in the ZWaveAPI .NET, I know that OpenZWave has implemented the association class, and I would suggest taking hints from them. This is a big missing point for ZWaveAPI.NET, and would be a very valued contribution.

As far as the process goes what you need to do:

Set the controller (ZWaveAPI.Net) in association mode (I am personally not a fan of auto association, so I would suggest this to be a mode of some sorts). Then for all detected units connected while in association mode, send the association command.

For a C++ implementation OpenZWave are doing it like this:

http://code.google.com/p/open-zwave/source/browse/trunk/cpp/src/command_classes/Association.cpp

 

Regards

 

Peter

Developer
Dec 3, 2012 at 5:18 PM

Thanks so much Peter,  I believe that is the info I have been searching for. 

 

If I get working,  I'll let you know ,  and try to push any applicable contributions up...(if they are worthy.). 

 

thanks,  

Nick P. 

Dec 29, 2013 at 7:20 PM
Hi Nick and Peter,

actually I have the same problem with the aeon labs multi sensor. So I would like to ask, if you managed, to get an event from the sensor, when motion is detected or if the association classes are implemented somewhere in beween? Or is there any other way, to get the information from the sensor?

Thank you very much and kind regards from germany,

Martin